Yeah.

February 05, 2012 02:24PM
This is from my transmuter script (much further down) and back then I had XP and everything in Zmud worked perfect and right and stuff and then I got Win 7 and now scripts are hit and miss. This works for me (I use it all the time).

It took a LOT of fighting with and what was weird to me is that the space " " is absolutely necessary. It will not work without that space there. So all of your prepsubbed items are going to have a single space that shoves them slightly to the right (I find it to be a kind of boon since I know which items are tweaked, they are off align slightly and they stick out some).

So...

{#sub " <@prepname> ~[<@PrepEffects>~]"} {PrepSubs} "PrepSubs"}

See that " < spot? Make sure that space is there or it won't work for some stupid reason.

There is a function that will evaluate stuff. %eval or something. Might be a different one for text values. Just remember the space and tell me if it's not working after that. I fought with it and fought with it and fought with it and eventually it was the space that made it work.


*** Edited to Add my parser settings

Script Parser Settings

Checked
Echo Commands
Echo Messages
Echo Scripts
Capture Commands
Gag Password
Trigger on COmmands
allow <> for expand
a=b syntax
strip "quotes"
null var references
allow ; comments
allow //comments
allow VBScript
Allow JScript

Unchecked
Show Triggers
Allow [] for eval

PM me your email if you can't figure it out and I'll send you a settings file that it works on for me.



Edited 1 time(s). Last edit at 02/05/2012 02:35PM by trewyn.
Subject Author Posted

Zmud - how do you trigger an echo to the end of that line

NbM(VIP) January 23, 2012 06:47PM

Re: Zmud - how do you trigger an echo to the end of that line

asthiss January 25, 2012 01:56AM

How would you do multiple words?

TripHitNdip February 02, 2012 01:25PM

This is what I use sometimes.

trewyn February 04, 2012 05:13PM

Dude, thank you so much, I need a bit of tweaking though.

TripHitNdip February 05, 2012 10:28AM

Yeah.

trewyn February 05, 2012 02:24PM

Actually just saw you said <> needs to be set to eval. Once I figure this out I'm sure I'll be golden! (n/t)

TripHitNdip February 05, 2012 10:44AM

And I'm having no luck :P if you see this, I sure would appreciate a PM or elaboration... I'll buy you a PBF :P (n/t)

TripHitNdip February 05, 2012 11:33AM

Bump! (n/t)

TripHitNdip February 03, 2012 10:08AM

I just now saw this, Thank You! (n/t)

NbM(VIP) February 02, 2012 01:17PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 43
Record Number of Users: 59 October 25, 2015
Record Number of Guests: 341 February 12, 2018